Can not get the micro usb connector to plug into my vanquish.

Merf

Silver Member
Jan 7, 2007
3,479
804
Northern Illinois
Detector(s) used
Whites XLT
Minelab vanquish, Quest x10 pro
Primary Interest:
All Treasure Hunting
I bought it about 6 months ago and don’t think it has been updated. The iron voluum is not adjustable as the update states. Anyone know a trick to plug it in?
 
OP
Merf

Merf

Silver Member
Jan 7, 2007
3,479
804
Northern Illinois
Detector(s) used
Whites XLT
Minelab vanquish, Quest x10 pro
Primary Interest:
All Treasure Hunting
  • Thread Starter
  • Thread starter
  • #3
Take your time, and make sure the cable end is orientated correctly. The connection is right on the motherboard so it's more delicate...
I took a picture of the socket and it looks a little odd. What do you think? If you zoom in it looks like the terminals are deformed.
60C5FE75-F70F-4304-BE1D-070CD35EC458.jpeg
 
OP
Merf

Merf

Silver Member
Jan 7, 2007
3,479
804
Northern Illinois
Detector(s) used
Whites XLT
Minelab vanquish, Quest x10 pro
Primary Interest:
All Treasure Hunting
  • Thread Starter
  • Thread starter
  • #6
Certainly does!
I think Minelab has a quality control problem. This, broken mounts on coils, my first 540 would not detect silver, had to return it. What do other members think? Are these being made in China now?
 

diamonddave

Jr. Member
Jan 4, 2021
83
200
WESTERN PA
Detector(s) used
MINELAB VANQUISH 540 PP
Primary Interest:
All Treasure Hunting
I think Minelab has a quality control problem. This, broken mounts on coils, my first 540 would not detect silver, had to return it. What do other members think? Are these being made in China now?
Hate to see this. I have two 540's with no real issues in two years of use.

I would first try to return it to where you bought it in exchange for another. It should be covered under the warranty. If they won't take it back, contact Minelab to try an get an RA for repair. They have a repair center in PA. That looks like an easy fix, maybe they can just swap the board out.

Good luck!
 
OP
Merf

Merf

Silver Member
Jan 7, 2007
3,479
804
Northern Illinois
Detector(s) used
Whites XLT
Minelab vanquish, Quest x10 pro
Primary Interest:
All Treasure Hunting
  • Thread Starter
  • Thread starter
  • #8
I think Minelab has a quality control problem. This, broken mounts on coils, my first 540 would not detect silver, had to return it. What do other members think? Are these being made in China now?
A better photo of the terminals inside the connector. I sent pics to Minelab service.
 

Attachments

  • 3BEF3985-B3DD-4C7C-A545-4F65AA562102.jpeg
    3BEF3985-B3DD-4C7C-A545-4F65AA562102.jpeg
    2.2 MB · Views: 21
Last edited:
OP
Merf

Merf

Silver Member
Jan 7, 2007
3,479
804
Northern Illinois
Detector(s) used
Whites XLT
Minelab vanquish, Quest x10 pro
Primary Interest:
All Treasure Hunting
  • Thread Starter
  • Thread starter
  • #9
A better photo of the terminals inside the connector. I sent pics to Minelab service.
Problem solved. Minelab service sent me authorization # for a return. i decided to try a couple of different mini connector cables before sending it back and actually got one to plug in and did the update. What a relief.
 

Top Member Reactions

Users who are viewing this thread

Latest Discussions

Top