Frustrated with my Equinox 800

Detecting Fool

Full Member
Jan 9, 2005
160
192
Stillwater, NY
Detector(s) used
Minelab Equinox 800
Prior to 2020 - Whites VX3, XLT, Spectrum XLT, 6000di and 1DB
Primary Interest:
Metal Detecting
My entire life, I have always used White's starting in 1981 with a 1 D/B. Over the years, I upgraded, but always with White's. Finally, in 2020, I decided to upgrade again and a day after I decided, White's announced they were retiring. When I contacted my local White's dealer they talked me into a detector that "wasn't a big boxy detector" which was the Minelab Equinox 800. First couple of uses using the factory settings worked out pretty good. Found a couple of Indian Heads on my very first outing, so I thought, wow, this is going to be an awesome detector. But then the pandemic hit, and I didn't really get out much for the rest of 2020. Rather then go into all the details, 2021 was a great year. I watched a few videos, made a few adjustments and made some incredible finds. 2022 started out the same way as 2021 ended. Incredible finds. And then for some reason, I started finding nothing but nails. I watched more videos and attempted to adjust the iron bias but for some reason, I could not make any adjustments, so I did a factory reset and then was able to make the adjustments to what had worked so well last year. But still, nothing but nails. And I mean, really strong high pitched dime and quarters signals and showing on the screens as what dimes and quarters should be are nails. So I adjusted FE completely to 0 and F2 completely to 0 and went out for three hours last night and everything is nails. At this point I am really missing my Whites. When I got a certain signal, I could be almost 100% certain it was what the detector was telling me it was.
So, with that said, is there any way to completely discriminate iron on the Equinox 800? I dont care if I miss gold or nickel. I just dont want to ever see another nail. Or do you think something is wrong with my machine?
Any advice would be greatly appreciated.
Thank you.
Anthony
 
Last edited:

bc5391

Sr. Member
Sep 23, 2016
281
292
Southern Arizona
Detector(s) used
Minelab ,XP
Primary Interest:
All Treasure Hunting
delete all the settings that you added from youtube, do a factory reset and start over.
Only dig repeatable signals, as you start learning your machine, then and only then make changes.
You probably notched out signals which is why you are only finding iron. For the most part the factory settings will get you by.
After the factory reset place a penny, nickle, dime, quarter- you get the idea, on the ground and for your first few hunts only dig those TDI;s after that start digging all signals that way you will learn the machine, you will also dig a million pull tabs trying to get that nickle, but you may also find a ring or 2.
 

traveller777

Silver Member
Aug 20, 2017
4,584
12,723
East Tennessee
Detector(s) used
Minelab CTX 3030 & Explorer
Primary Interest:
All Treasure Hunting
delete all the settings that you added from youtube, do a factory reset and start over.
Only dig repeatable signals, as you start learning your machine, then and only then make changes.
You probably notched out signals which is why you are only finding iron. For the most part the factory settings will get you by.
After the factory reset place a penny, nickle, dime, quarter- you get the idea, on the ground and for your first few hunts only dig those TDI;s after that start digging all signals that way you will learn the machine, you will also dig a million pull tabs trying to get that nickle, but you may also find a ring or 2.
Great advice. Let us know how that does.
 

Treasure_Hunter

Administrator
Staff member
Jul 27, 2006
45,985
48,738
Florida
Detector(s) used
Minelab_Equinox_ 800 Minelab_CTX-3030 Minelab_Excal_1000 Minelab_Sovereign_GT Minelab_Safari Minelab_ETrac Whites_Beach_Hunter_ID Fisher_1235_X
Primary Interest:
All Treasure Hunting
Agree with BC, do a reset and start over, all ferrous targets (nails) should be in the 0 to -9 You should not be digging iron unless you want to be. Are you sure you were not in all metal?

bbhnox.jpg





bgt.jpg
 
Last edited:
OP
D

Detecting Fool

Full Member
Jan 9, 2005
160
192
Stillwater, NY
Detector(s) used
Minelab Equinox 800
Prior to 2020 - Whites VX3, XLT, Spectrum XLT, 6000di and 1DB
Primary Interest:
Metal Detecting
  • Thread Starter
  • Thread starter
  • #5
delete all the settings that you added from youtube, do a factory reset and start over.
Only dig repeatable signals, as you start learning your machine, then and only then make changes.
You probably notched out signals which is why you are only finding iron. For the most part the factory settings will get you by.
After the factory reset place a penny, nickle, dime, quarter- you get the idea, on the ground and for your first few hunts only dig those TDI;s after that start digging all signals that way you will learn the machine, you will also dig a million pull tabs trying to get that nickle, but you may also find a ring or 2.
I actually did do that last month. Reset to factory setting until I attempted to adjust the iron bias last night and try that out.
 

smokeythecat

Gold Member
Nov 22, 2012
20,163
39,130
Maryland
🥇 Banner finds
10
🏆 Honorable Mentions:
1
Detector(s) used
XP Deus II
Primary Interest:
All Treasure Hunting
I agree with the others. Forget the youtube adjustments. Also, there are times all machines will read BENT nails as marginally good. Test some coins outside on the ground. It is theoretically possible someone got to the spots before you and cleaned them out. I have had that happen to me.
 
Last edited:
OP
D

Detecting Fool

Full Member
Jan 9, 2005
160
192
Stillwater, NY
Detector(s) used
Minelab Equinox 800
Prior to 2020 - Whites VX3, XLT, Spectrum XLT, 6000di and 1DB
Primary Interest:
Metal Detecting
  • Thread Starter
  • Thread starter
  • #7
I agree with the others. Forget the youtube adjustments. Also, there are times all machines will read BENT nails as marginally good. Test some coins outside on the ground. It is theoretically possible someone got to the spots before you and cleaned them out. I have had that happen to me.
Its not sometimes. Its every single target. I did a complete reset again yesterday and then went to the place that only I have ever hunted and every single target was a nail. This is a place where I have been hunting for 20 years and have found several large cents, thousands of indian heads, lots of silver coins (seated era through 1964) and regardless of what the number, excluding the obvious iron numbers, I dug. 20-21. Nail. 24-25. Nail. 27-29. Nail.

The other thing that concerns me is when I do a factory reset, if i go an change the iron bias to 2 or 3, if I decide to edit it again, I can not. I have to do a factory reset again to get the option to change FE or F2.

Anthony
 

McKinney_5900

Hero Member
Jul 30, 2010
955
680
I tinkered around with the IB settings when I first got my Equinox and wasted time and lost confidence, so I performed 2 full resets in a row, for certainly, and I only change sensitivity and recovery now speed since then. I can't recall the last bent nail I've found.

I just trust the ML design engineers to have made the best firmware setup. Honestly? I have never understood the way that iron balance even works.

I have fun with the factory settings.
 

Top Member Reactions

Users who are viewing this thread

Top