Golden mask 1+ (UK)

mrkuba556

Newbie
Oct 14, 2021
2
2
Hello all, I am new here and if I post in the wrong place please tell me.
I bought last week a golden mask 1+ uk (from private person in uk) and he scamed me becasue I think the detector is broken.
Problem is that when I turning it on I dont have response from item which I place on the floor or the detector freaking out and giving one signal all time. I think it may be flooded, so I am looking for company/person or advice in UK to repair my detector...
Im tried to contact with him but he dont response on my messages..
Thank You for help.
 

pepperj

Gold Member
Feb 3, 2009
19,909
55,223
Detector(s) used
Deus, Minelab 3030, E-Trac,
Primary Interest:
Relic Hunting
Go outside, try it testing it there.
Probably picking up everything in/under the floor-like wiring/plumbing/metal duct work.
 
OP
M

mrkuba556

Newbie
Oct 14, 2021
2
2
  • Thread Starter
  • Thread starter
  • #3
Go outside, try it testing it there.
Probably picking up everything in/under the floor-like wiring/plumbing/metal duct work.
Arleady testing outside same effect. Its something like I turn it on 10-15 seconds normally working then quiet or 1 uninterrupted signal or freaking out.
I can send you video of this problem on private message.
 

pepperj

Gold Member
Feb 3, 2009
19,909
55,223
Detector(s) used
Deus, Minelab 3030, E-Trac,
Primary Interest:
Relic Hunting
Is there any videos online demos?
 

Top Member Reactions

Users who are viewing this thread

Top