Welcome guest, is this your first visit?
Member
Discoveries
 
Results 1 to 1 of 1
  1. #1
    us
    Nov 2006
    N. Alabama
    Minelab X-terra 70, AT Pro, Tesoro Tejon, ML X-terra 50
    685
    13 times
    Relic Hunting

    X-terra 10.5 DD Coil Not Working Properly

    I'm in the process of replacing a coil that I suspect has a cracked cable. I got the dreaded CU error and the volume was greatly reduced. So, replaced it with the stock coil and things went back to normal. Has anyone tried fixing one of these coils or is interested in trying? Figured I would ask here before I just throw the coil away.
    Relic hunting consists of a series of misadventures interspersed by occasional moments of glory.

 

 

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 3
    Last Post: Jun 29, 2017, 02:11 PM
  2. Is My Garret 350 working Properly??
    By Hookedondetecting in forum Garrett
    Replies: 13
    Last Post: Jul 31, 2013, 08:10 AM
  3. Is my Whites GMT working properly?
    By bward916 in forum Metal Detecting
    Replies: 2
    Last Post: Jun 05, 2013, 12:00 PM
  4. Ace 350 LCD screen not working properly
    By Pepperlizard in forum Garrett
    Replies: 1
    Last Post: Jul 10, 2012, 07:27 PM
  5. Working boulder properly?
    By CharlesP in forum Panning For Gold
    Replies: 6
    Last Post: May 25, 2012, 03:08 AM
Powered by vBadvanced CMPS v4.3.0